当前位置:错新网文章中心服务器安全维护 → 局域网中代理服务器、路由器的配置方案(2)

局域网中代理服务器、路由器的配置方案(2)

减小字体 增大字体 作者:admin  来源:www.hack50.com  发布时间:2011-12-15 7:21:08
(2)路由器的配置

  en
  config t
  ip nat pool c2610 211.90.139.41 211.90.139.42 netmask 255.255.255.252
  (定义一个地址池c2601,其内包含了两个空闲的合法IP地址,供NAT转换时使用)
  int e0/0
  ip address 192.168.0.3 255.255.255.0
  ip nat inside
  exit
  (设置以太口的IP地址,并设置其为连接内部网的端口)
  interface s0/0
  ip address 211.90.137.25 255.255.255.252
  ip nat outside
  exit
  (设置广域网端口的IP地址,并设置其为连接外部网的端口)
  ip route 0.0.0.0 0.0.0.0 211.90.137.26
  (设置动态路由)
  access-list 2 permit 192.168.0.1 0.0.0.255
  (建立访问控制列表)
  ! Dynamic NAT
  !
  ip nat inside source list 2 pool c2610 overload
  (建立动态地址翻译)
  line console 0
  exec-timeout 0 0
  !
  line vty 0 4
  end
  wr

  (保存所作的设置)

  3. 工作站的配置

  要求使用静态IP地址,在TCP/IP属性中进行设置,并设置关网为192.168.0.3(路由器以太口IP地址),设置DNS为接入商提供的地址,浏览器等上网工具中无需作任何特殊设置。

二、通过代理服务器访问INTERNET资源的配置

  1. 总体的思路和设备连接方法

  利用代理服务器方式访问INTERNET资源,优点是可以利用代理服务器提供的CACHE服务来提高INTERNET的访问速度和效率。比较适合工作站较多的单位使用。缺点是需要专门配备一台计算机作为代理服务器,增加了投资成本;且较第一种法方还需多占用两个合法IP地址,网络安全性不高。

  采用这种方案来访问互联网,设备连接方法如下:

  代理服务器上安装两块网卡,一块连接内部网,设置内部私有地址;另一块连接路由器以太口,设置联通分配的合法地址(211.90.139.42),并设置其网关为211.90.139.41(路由器以太口)

  路由器以太口也设置联通分配的合法IP地址(211.90.139.41)

  这样,将设备连接好后,在代理服务器上安装代理软件,并在工作站上设置代理即可访问INTERNET。

  2. 路由器的配置

  (1) 网络连接示意图:

  说明:在上图中,单位内的所有计算机通过交换机直接与代理服务器上的内部网网卡(192.168.0.4)通讯,然后在代理服务软件的控制之下经过路由器访问INTERNET。

  (2)路由器的配置

  en
  config t
  int e0/0
  ip address 211.90.139.41 255.255.255.252
  exit
  (设置以太口的IP地址)
  interface s0/0
  ip address 211.90.137.25 255.255.255.252
  exit
  (设置广域网端口的IP地址)
  ip route 0.0.0.0 0.0.0.0 211.90.137.26
  ip routing
  (设置动态路由,并激活路由)
  end
  wr
  (保存所作的设置)

3. 代理服务器的设置

  代理服务器必须按装两块网卡,一块用于连接内部局域网,设IP地址为内部私有地址(如:192.168.0.4 netmask 255.255.255.0)无需设网关。另一块用于连接路由器,设置联通分配的合法地址(211.90.139.42 netmask 255.255.255.252),并设置其网关为:211.90.139.41(路由器以太口)。

  按照上面的方法设置好网卡后,再安装一套代理软件即可。(如:MS PROXY SERVER 2.0、WINGATE等,代理软件的安装调试方法请参阅其它资料)

  4. 工作站的设置

  (1) INTERNET EXPLORER设置

  工具菜单->internet选项->连接->局域网设置->使用代理服务器->地址:192.168.0.4端口:80->确定。
(2)其他软件的设置请参阅软件说明。


本文引用网址:

在下列搜索引擎中搜索“局域网中代理服务器、路由器的配置方案(2)”的相关信息:

谷歌搜索 百度搜索 雅虎搜索 搜狗搜索 搜搜搜索 必应搜索 有道搜索
你可能还喜欢以下文章
  • 1韩国女主播性爱视频 韩成珠更多...
  • 2韓成珠視頻qvod 韓國女主播性愛...
  • 3四川美院女生遭前男友发艳照报...
  • 4林晨钰爆奶门照片ed2k 林晨钰爆...
  • 5王婷不雅视频 王婷全裸艳照 王...
  • 1织梦dede模板调用标签大全
  • 2两年的站长织梦生涯DedeCMS陪我...
  • 3Dedecms会员注册验证邮箱的实现...
  • 4Google新服务 在404页面提供广...
  • 5新站快速提升网站的PR值
  • 1中国女大学生的淫靡生活
  • 2合肥艳照门事件 合肥艳照门全套...
  • 3日本AV六级试卷 (附标准答案)
  • 4中国女大学生的校园生活
  • 5偷拍男女练功房里的那点事 看后...
  • 1加密无痕Win7系统让U盘成为个人...
  • 224日预警:将感染电脑变成FTP服...
  • 3Linux中Gnome与KDE字体大小不同...
  • 4Win2008系统活动目录权限管理服...
  • 5如何做服务器安全维护?有哪些...
  • 赞助商广告

    图片文章导读